Comments are closed
cJass on the Google Code.
Our BugTracker (recommend to post bugreports and features request there).
Beta tester notes.
all times are GMT +03:00Latest posts
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 [23] 24 25 26 27
posted at 25/08/09 23:06Dark Dragon
I see... ADOLF didn't fix it. I've told him, he should look into it tomorrow
Fixed
ADOLF
posted at 25/08/09 22:49Dark Dragon
posted at 25/08/09 22:46Dark Dragon
OMG, what a mess.. I don't know, what's the matter, so <a href="http://cjass.xgm.ru/files/?cJass_AdicHelper_v01030309_exe.zip">here</a> is a link to 1.3.3.9 for now.
I'll contact ADOLF tomorrow because he's already sleeping now.
VD
posted at 25/08/09 22:42Dark Dragon
posted at 25/08/09 18:16Strilanc
For now it's `...` like
<div class="code"><b>define</b> assert(condition) = {
if (!condition) {
BJDebugMsg("Assertion Failure: " + `condition`)
}
}</div>
And soon both #condition will be added, which does the same thing, and parsing this inside of the string will be done.
<div class="code"><b>define</b> assert(condition) = {
if (!condition) {
BJDebugMsg("Assertion Failure: " + `condition`)
}
}</div>
And soon both #condition will be added, which does the same thing, and parsing this inside of the string will be done.
The manual is coming later this week, just be patient and keep asking about things, which you don't know.
VD
posted at 25/08/09 15:49Dark Dragon
posted at 25/08/09 15:32Dark Dragon
if you define <allocate()>, the thing will be replaced only if you write
<div class="code">onCreate() {
allocate()
...
}</div>
, so it's the right way of doing it.
<div class="code">onCreate() {
allocate()
...
}</div>
, so it's the right way of doing it.
As for while define, "whilenot cond { ... }" is already an in-language construct and can be used without round braces around the condition, so you just have to replace "whilenot" to "whilenot not" like
<div class="code">define while = whilenot not</div>
<div class="code">define while = whilenot not</div>
VD
posted at 25/08/09 15:19Dark Dragon
In this case, you should use
<div class="code"><allocate()> = thistype this = thistype.alloc ## ate()</div>
or
<div class="code"><allocate()> = { thistype this = thistype.alloc ## ate() }</div>
for better readability.
<div class="code"><allocate()> = thistype this = thistype.alloc ## ate()</div>
or
<div class="code"><allocate()> = { thistype this = thistype.alloc ## ate() }</div>
for better readability.
VD
posted at 25/08/09 15:00Dark Dragon
posted at 25/08/09 14:56Dark Dragon
posted at 25/08/09 14:24Dark Dragon
Adolf will fix that now =)
VD
posted at 25/08/09 14:19Dark Dragon
Fixed.
ADOLF
posted at 25/08/09 02:55Strilanc
I know that. For now, the way is to separate the declaration and initialization of the variables that shouldn't be moved up, eg:
unit u; u = CreateUnit(...)
unit u; u = CreateUnit(...)
Hope, I will be able to persuade Adolf to implement the detection algorithm for such cases.
VD
posted at 25/08/09 02:39Dark Dragon
posted at 24/08/09 21:12Dark Dragon
I understand, what you're talking about. I think, it could be
void test() {
integer i = GetRandomInt(1, 5)
if (i <= 2) { KillUnit(GetTriggerUnit()) }
else { KillUnit(GetKillingUnit()) }
}
integer i = GetRandomInt(1, 5)
if (i <= 2) { KillUnit(GetTriggerUnit()) }
else { KillUnit(GetKillingUnit()) }
}
to avoid excessive variables. We'll discuss ternary operator with Adolf later =)
VD
posted at 23/08/09 22:16Dark Dragon
posted at 22/08/09 18:37Dark Dragon
posted at 22/08/09 18:01Dark Dragon
no)
from vJass readMe:
Hint: You can use textmacro_once in a similar way to library_once.
posted at 22/08/09 17:37ADOLF
posted at 22/08/09 17:32Dark Dragon
thx, i fix it (and ++.n) too =)
ADOLF
posted at 22/08/09 15:04Dark Dragon
no, its not bug, all variable declaration go on top
use:
nothing test() {
CreateNUnitsAtLoc(...)
unit u /* <--- be moved */; u = bj_lastCreatedUnit
}
CreateNUnitsAtLoc(...)
unit u /* <--- be moved */; u = bj_lastCreatedUnit
}
ADOLF
posted at 22/08/09 13:26Dark Dragon
yes, <> will work too
ADOLF